Tag Archives: emerge

Problema aggiornamento texlive-basic gentoo

Durante uno degli ultimi aggiornamenti della mia distribuzione gentoo, mi sono imbattuto in un errore di compilazione del pacchetto texlive-basic.
L’errore era il seguente:

failed to build format texmf/fmtutil/format.texlive-basic.cnf

La soluzione è abbastanza semplice, si tratta di emergere il pacchetto luatex che sembra essere missing:

emerge -1 luatex

Una volta terminata l’installazione, potete rilanciare la procedura di aggiornamento e non dovreste avere più problemi.

Skype: Aggiornarlo su gentoo

Ecco qui un altro piccolo tip and trick per linux gentoo. Questa volta relativo al software skype.

Se avete questo software  installato, e durante l’aggiornamento ricevete un messaggio di warning relativo ad una nuova licenza da accettare per poter aggiornare quel pacchetto, a versioni dalla 4 in su dovete sbloccare in emerge la licenza con la quale viene fornito.

In gentoo, il gestore dei pacchetti emerge permette di accettare o rifiutare l’installazione di particolari licenze. Uno dei modi per farlo é accettare la licenza per tutti i software che la usano, quindi si interviene a livello di make.conf modificando la entry ACCEPT_LICENSE.

Invece nel nostro caso invece noi vogliamo  accettare una licenza specifica solo per il pacchetto skype da una certa versione in su (la 4).  In questo caso creiamo il seguente file:

/etc/portage/package.license/skype

e aggiungiamo la sequente riga:

>=net-im/skype-4.0.0.8-r1 skype-4.0.0.7-copyright

Questa stringa dice ad emerge, di accettare la licenza se skype-4.0.0.7-copyright se si sta installando una versione di skype superiore alla 4.0.0.8-r1

E ora al prossimo aggiornamento di sistema, anche il pacchetto skype verrá aggiornato senza problemi. Per maggiori informazioni sulla gestione delle licenze vi rimando alla  documentazione ufficiale di gentoo: http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2&chap=1#doc_chap4 (in italiano)

Gentoo: java nel browser

Recentemente nel seguire alcuni tutorial java che mostravano l’output all’interno di alcune applet, ho constatato con disappunto che il mio browser non era stato mai configurato per visualizzarle. Quindi qui vi spiegheró come abilitare i plugin java nei browsers della nostra gentoo.

Continue reading Gentoo: java nel browser

Gentoo: Aiuto i miei programmi non funzionano piu!

Per chi usa gentoo da poco tempo,  puo capitare dopo uno o piu aggiornamenti di tentare di lanciare un programma e ricevere il seguente errore:

mplayer: error while loading shared libraries: libx264.so.115: cannot open shared \
object file: No such file or directory

questo problema si puo’ verificare quando viene aggiornata una delle librerie da cui dipende il programma che ha smesso di funzionare. La soluzione il piu delle volte e’ molto semplice, basta infatti dare il comando:

revdep-rebuild

E attendere. Questo comando si preoccupa di controllare quali programmi e librerie hanno delle shared libraries da cui dipendono mancanti, una volta individuati i pacchetti con questo problema si occupa di ricompilarli ri-emergendo i pacchetti e le librerie mancanti se necessario.

Nel mio caso ho avuto problemi con vlc e mplayer, e questo comando ha risolto.